OpenRoads Designer CONNECT Edition SDK Help

LinearPointProjectionBySegmentsResult Class

Defines a CLinear Point by Projection by Segment.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public class LinearPointProjectionBySegmentsResult
Inheritance → LinearPointProjectionBySegmentsResult

Properties

IsReverseArray Gets the array of Reverse-flag for each segment.
IsReverseArrayAP Gets the array of Reverse-flag for each segment.
SegmentPointsOnProjectedArray Gets the array of points collections (segments points)along each segment of “projected” element (The element to project on).
SegmentPointsOnThisArray Gets the array of points collections (segments points) along each segment of “this” element (The element to be project).

Methods

GetCouplesEnum Gets an enumerator on all the couple of points of LinearPointProjectionBySegmentsResult.

See Also